Поиск в списке справочника по подстроке...

Ответить


Этот вопрос предназначен для предотвращения автоматической отправки данных форм спам-ботами.
Смайлики
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode ВКЛЮЧЕН
[img] ВКЛЮЧЕН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ
Обзор темы
   

Развернуть Обзор темы: Поиск в списке справочника по подстроке...

Re: Поиск в списке справочника по подстроке...

Сообщение cobra77777 » 25 ноя 2016, 11:21

Спасибо большое получилось.

Re: Поиск в списке справочника по подстроке...

Сообщение admin » 25 ноя 2016, 00:41

Вот пример
Вложения
Пример.zip
(34.92 KiB) Скачиваний: 115

Re: Поиск в списке справочника по подстроке...

Сообщение cobra77777 » 24 ноя 2016, 17:32

Да исправил, но поиск всё равно не идёт :oops:

Re: Поиск в списке справочника по подстроке...

Сообщение admin » 24 ноя 2016, 16:55

Для базы в режиме совместимости с версией 8.2 нужно так:
Код: выделить все
&НаКлиенте
Процедура ВыполнитьПоиск (СтрокаОтбора)
   Для каждого ЭлементОтбора Из Список.Отбор.Элементы Цикл
      Если ЭлементОтбора.Представление = "ПоискПоПодстроке" Тогда
...

Re: Поиск в списке справочника по подстроке...

Сообщение admin » 24 ноя 2016, 12:12

В свойствах конфигурации какое значение установлено для режима совместимости?

Re: Поиск в списке справочника по подстроке...

Сообщение cobra77777 » 23 ноя 2016, 21:29

Извините, но и "Список" тоже не работает.
Вложения
1с_8.3.9.1818.jpg
1с_8.3.9.1818.jpg (162.27 KiB) Просмотров: 3042

Re: Поиск в списке справочника по подстроке...

Сообщение admin » 23 ноя 2016, 10:07

cobra77777 писал(а):ТекущийЭлемент = Элементы.Список?????????; <----- вот здесь проблема в моём случае не выдаёт СписокТехника :(

Тогда пишите как выдает, наверное просто "Список".

Re: Поиск в списке справочника по подстроке...

Сообщение cobra77777 » 22 ноя 2016, 20:43

весь код:
В Вашем примере Справочник -> Номенклатура, в моём случае Справочник ->Техника.

> Кроме этого, для корректной работы кода обработчика ИзменениеТекстаРедактирования в настройках поля СтрокаПоиска свойство ОбновлениеТекстаРедактирования необходимо установить в значение НеИспользовать.
- Выполнено.

&НаКлиенте
Процедура СтрокаПоискаПриИзменении(Элемент)
ВыполнитьПоиск (СтрокаПоиска);
ТекущийЭлемент = Элементы.Список?????????; <----- вот здесь проблема в моём случае не выдаёт СписокТехника :(

КонецПроцедуры

&НаКлиенте
Процедура СтрокаПоискаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ВыполнитьПоиск (Текст);
КонецПроцедуры


&НаКлиенте
Процедура ВыполнитьПоиск (СтрокаОтбора)

Для каждого ЭлементОтбора Из Список.КомпоновщикНастроек.Настройки.Отбор.Элементы Цикл
Если ЭлементОтбора.Представление = "ПоискПоПодстроке" Тогда
ЭлементОтбора.Использование = СокрЛП (СтрокаОтбора) <> "";
Если ЭлементОтбора.Использование Тогда
Для каждого ЭлементПоиска из ЭлементОтбора.Элементы Цикл
ЭлементПоиска.ПравоеЗначение = СтрокаОтбора;
КонецЦикла;
Элементы.Список.Отображение = ОтображениеТаблицы.Список;
Иначе
Элементы.Список.Отображение = ОтображениеТаблицы.ИерархическийСписок;
КонецЕсли;
Прервать;
КонецЕсли;

КонецЦикла;

КонецПроцедуры

Re: Поиск в списке справочника по подстроке...

Сообщение admin » 21 ноя 2016, 23:31

&НаКлиенте
Процедура СтрокаПоискаИзменениеТекстаРедактирования(Элемент, Текст, СтандартнаяОбработка)
СтандартнаяОбработка = Ложь;
ВыполнитьПоиск (Текст);
КонецПроцедуры

&НаКлиенте
Процедура СтрокаПоискаПриИзменении(Элемент)
Поиск(СтрокаПоиска);
ТекущийЭлемент = Элементы.СписокНоменклатуры;
КонецПроцедуры

Кроме этого, для корректной работы кода обработчика ИзменениеТекстаРедактирования в настройках поля СтрокаПоиска свойство ОбновлениеТекстаРедактирования необходимо установить в значение НеИспользовать.

Вернуться наверх

cron