Тема для тех, кому лень создавать новую тему :)

Ответить


Этот вопрос предназначен для предотвращения автоматической отправки данных форм спам-ботами.
Смайлики
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode ВКЛЮЧЕН
[img] ВКЛЮЧЕН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ
Обзор темы
   

Развернуть Обзор темы: Тема для тех, кому лень создавать новую тему :)

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Elizarov.Aleksey » 04 мар 2019, 08:01

Доброго времени суток. Подскажите как можно вывести файл (изображение) загруженное в базу. к примеру: если мы в документ прикрепили файл(рисунок) что бы в печати не название этого рисунка было, а сам рисунок. Документ с реквизитом со ссылкой на справочники "Файлы"
Код: выделить все
Процедура Печать123(ТабДок, Ссылка) Экспорт
   Макет = Документы.ПаспортЛЭП.ПолучитьМакет("Печать123");
   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   ПаспортЛЭП.Схема.ФайлХранилище КАК Схема,
   |   Файлы.ФайлХранилище КАК ФайлХранилище
   |ИЗ
   |   Документ.ПаспортЛЭП КАК ПаспортЛЭП
   |      ЛЕВОЕ СОЕДИНЕНИЕ Справочник.Файлы КАК Файлы
   |      ПО ПаспортЛЭП.Схема = Файлы.Ссылка";
   
   
   Выборка = Запрос.Выполнить().Выбрать();
   ВставлятьРазделительСтраниц = Ложь;      
   Пока Выборка.Следующий() Цикл
      Если ВставлятьРазделительСтраниц Тогда
         ТабДок.ВывестиГоризонтальныйРазделительСтраниц();
      КонецЕсли;
   КонецЦикла;
   Данные = Выборка.Схема.Получить();
   Если ТипЗнч(Данные) = Тип("Картинка") Тогда
      лкКартинка = Данные;
   ИначеЕсли ТипЗнч(Данные) = Тип("ДвоичныеДанные") Тогда
      лкКартинка = Новый Картинка(Данные, Ложь);
   КонецЕсли;   
      
   ТабДок = Новый ТабличныйДокумент;
   ОбластьРисунок = Макет.ПолучитьОбласть("Рисунок");
   Попытка
      Путь = КаталогВременныхФайлов()+ "Картинка"+Формат(ТекущаяДата(),"ДФ=yyyyMMddЧЧммсс")+".bmp";
      КартинкаВПамяти = Выборка.Схема.Получить();
      КартинкаВПамяти.Записать(Путь);
      ОбластьРисунок.Рисунки.Картинка.Картинка = Новый Картинка(Путь);
   Исключение
      ОбластьРисунок.Рисунки.Картинка.Картинка = Новый Картинка;
   КонецПопытки;
   
   ТабДок.Вывести(ОбластьРисунок);
   /////////////////////////////////////////////////////////////////////////////////////////////////////
   ВставлятьРазделительСтраниц = Истина;
      
КонецПроцедуры
выводит пустой макет. В выборке значение = Хранилище Значений

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение admin » 03 июл 2018, 21:27

Добрый день!
Попробуйте так:
Код: выделить все
   Для каждого Элемент Из Элементы Цикл
      Если ТипЗнч(Элемент)=Тип("ТаблицаФормы") Тогда
         Элемент.КоманднаяПанель.ПодчиненныеЭлементы[Элемент.Имя+"Найти"].ТолькоВоВсехДействиях = Ложь;
         Элемент.КоманднаяПанель.ПодчиненныеЭлементы[Элемент.Имя+"Найти"].Отображение = ОтображениеКнопки.КартинкаИТекст;
      КонецЕсли;
   КонецЦикла;   

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 03 июл 2018, 16:35

Добрый день!
Как правильно организовать добавление стандарных команд формы на командную панель? Необходимо добавить в командную панель табличных частей документа кнопку "Найти".
Я делаю так
Для каждого Элемент из ЭтаФорма.Элементы Цикл
Если типЗНЧ(Элемент) = Тип("ТаблицаФормы") Тогда
//вот здесь неправильно у меня, так как я добавляю новую, а надо подключиться к существующей стандартной команде "Найти"
Команда = ЭтаФорма.Команды.Добавить(Элемент.Имя + "Найти");
Команда.Действие = Элемент.Имя + "Найти";
//

Кнопка = ЭтаФорма.Элементы.Добавить(Элемент.Имя + "ВыполнитьНайти", Тип("КнопкаФормы"), Элемент.КоманднаяПанель);
Кнопка.Заголовок = "Найти";
Кнопка.Отображение = ОтображениеКнопки.КартинкаИТекст;
Кнопка.ИмяКоманды = Элемент.Имя + "Найти"; //здесь должна быть команда "Найти" из стандартных команд данной табличной части
КонецЕсли;
КонецЦикла;

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Ирина » 06 июн 2018, 16:35

Вопрос отпал.Разобралась.

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Ирина » 06 июн 2018, 09:41

Добрый день.Необходимо, чтобы в справочнике если ВидДокумента инструкция и ДатаДействияОкончания меньше текущей даты, строки окрашивались в красный цвет. В модуле формы в процедуре ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)добавила небольшой код,который создает условие в Условном оформление списка. Когда захожу в 1с в режиме предприятие Условие создается, но не отрабатывает. Не подскажите в чем может быть проблема? Спасибо.

//=================================================
Список.УсловноеОформление.Элементы.Очистить();
ЭлементУсловногоОформления =Список.УсловноеОформление.Элементы.Добавить();

ГруппаЭлементовОтбора = ЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
ГруппаЭлементовОтбора.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИ;

ЭлементОтбора = ГруппаЭлементовОтбора.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДатаОкончанияДействия");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = ТекущаяДата();

ЭлементОтбора = ГруппаЭлементовОтбора.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ВидДокумента");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = "Инструкция";

ЭлементОформления = ЭлементУсловногоОформления.Оформление.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ЦветТекста"));
ЭлементОформления.Использование = Истина;
ЭлементОформления.Значение = Новый Цвет(255, 0, 0);
//

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Elizarov.Aleksey » 14 янв 2018, 07:15

Разобрался со страницами. полностью готовая форма. https://cloud.mail.ru/public/MdDG/6gjC2nMRe

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Elizarov.Aleksey » 13 янв 2018, 00:06

Доброго времени суток. Всех с прошедшими праздниками!)))
Хотел отдельно поздравить Сергея с новым годом. что бы новый год был еще лучше!! Спасибо Вам, жалею что не смог в последний день не смог придти.
По теме, кто подскажет в каком блоке было про печатную форму с переносам по страницам?
Печатная форма "Акт на передачу прав" БУХ 2.0 https://cloud.mail.ru/public/BXV7/W7cgtms7W работает все кроме переноса по страница :D может кому пригодиться)) доделаю выложу полностью исправную. Изображение

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 31 авг 2017, 12:29

Сначала отобрала в запросе данные из СрезПоследних с единицей измерения "т", потом в отобрала данные из СрезПоследних все остальные без единицы измерения "т". Далее связала полученные две таблицы
Выбрать ЕстьNULL(СрезПоТонне.НужноеПоле,СрезВсего.НужноеПоле) из СрезПоТонне
полное соединение СрезВсего по СрезПоТонне.Номенклатура=СрезВсего.Номенклатура
Как-то так...

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение skameykin22 » 20 авг 2017, 11:28

И как решили свой вопрос?

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 26 июл 2017, 12:05

Здравствуйте! У меня никак не получается организовать запрос: Если в регистре сведений СрезПоследних отсутствует запись с единицей измерение=т., тогда берем последнюю запись с любой единицей измерения. Помогите, пожалуйста! Может кто-то сталкивался с похожей задачей.

Вернуться наверх

cron