Как при входе в конфигурацию..... ?

Ответить


Этот вопрос предназначен для предотвращения автоматической отправки данных форм спам-ботами.
Смайлики
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode ВКЛЮЧЕН
[img] ВКЛЮЧЕН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ
Обзор темы
   

Развернуть Обзор темы: Как при входе в конфигурацию..... ?

Re: Как при входе в конфигурацию..... ?

Сообщение cobra77777 » 21 мар 2018, 09:29

Всё приехал :).
Спасибо за хелп.

Re: Как при входе в конфигурацию..... ?

Сообщение admin » 20 мар 2018, 22:18

Потому, что эти команды доступны только на клиенте и в серверном модуле их вызвать нельзя.
В серверном модуле нужно проанализировать пользователей и вернуть результат на клиент, где можно выдавать сообщения и завершать работу.

Re: Как при входе в конфигурацию..... ?

Сообщение cobra77777 » 20 мар 2018, 20:30

admin писал(а):В модуле управляемого приложения:
Процедура ПередНачаломРаботыСистемы(Отказ)
ОбщийМодуль.ПроверкаКоличестваВходовВСистему(Отказ);
КонецПроцедуры

В серверном модуле «ОбщийМодуль»:
Процедура ПроверкаКоличестваВходовВСистему (Отказ)
// Код
..................................................................................................................................................
Можете подсказать почему выходит ошибка.
Код написал, но при "Проверки модуля" выходит ошибка: свойства Свойство_Общий Модуль.jpg прикрепил.

Предупреждение ("Пользователем с таким именем уже выполнен вход в систему");
ЗавершитьРаботуСистемы(Ложь);
Возврат;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

{ОбщийМодуль.ОбщийМодуль.Модуль(15,11)}: Процедура или функция с указанным именем не определена (Предупреждение)
<<?>>Предупреждение ("Пользователем с таким именем уже выполнен вход в систему"); (Проверка: Сервер)
{ОбщийМодуль.ОбщийМодуль.Модуль(17,6)}: Процедура или функция с указанным именем не определена (ЗавершитьРаботуСистемы)
<<?>>ЗавершитьРаботуСистемы(Ложь); (Проверка: Сервер)

КонецПроцедуры
Вложения
Свойство_Общий Модуль.jpg
Свойство_Общий Модуль.jpg (43.21 KiB) Просмотров: 1186

Re: Как при входе в конфигурацию..... ?

Сообщение admin » 20 мар 2018, 14:44

В модуле управляемого приложения:
Процедура ПередНачаломРаботыСистемы(Отказ)
ОбщийМодуль.ПроверкаКоличестваВходовВСистему(Отказ);
КонецПроцедуры

В серверном модуле «ОбщийМодуль»:
Процедура ПроверкаКоличестваВходовВСистему (Отказ)
// Код
КонецПроцедуры

Re: Как при входе в конфигурацию..... ?

Сообщение cobra77777 » 20 мар 2018, 14:25

Добрый день!
Правильно я Вас понял:
&НаСервере
Процедура ПередНачаломРаботыСистемы(Отказ)

// САМ КОД

КонецПроцедуры


&НаКлиенте
Функция Старт()

ПередНачаломРаботыСистемы();

КонецФункции

Re: Как при входе в конфигурацию..... ?

Сообщение admin » 19 мар 2018, 22:24

Это не имеет значения.
В модуле управляемого приложения вызываете функцию серверного общего модуля,
а весь код реализуете в серверном модуле.

Re: Как при входе в конфигурацию..... ?

Сообщение cobra77777 » 19 мар 2018, 21:08

Хорошо, но мне нужно сделать через Управл.приложение.

Re: Как при входе в конфигурацию..... ?

Сообщение admin » 19 мар 2018, 20:52

Добрый день!
Я бы не спешил делать какие-либо регистры.
Почитайте о методе "ПолучитьСоединенияИнформационнойБазы" ...

Как при входе в конфигурацию..... ?

Сообщение cobra77777 » 19 мар 2018, 14:17

Здравствуйте!

Управляемая форма. Платформа 8.3.11.3034.Самописная конфигурация.

Вопрос: как при входе пользователя в конфигурацию выдавал бы диалог:
"Вы зашли в программу 1 раз". В след.раз 2 раз. и т.д.
Подсказали, что нужно в Регистре сведений завести : измерения (в моем случае СправочникСсылка.Сотрудники), ресурсы (в моем случае Количество Число Длина: 10, точность: 0). В модуле управляемого приложения выбрал событие Процедура ПередНачаломРаботы Системы (Отказ) загвоздка в коде :(.

Заранее спасибо.

Вернуться наверх