поле ввода вывести реквизит из справочника отличный от наим.

Ответить


Этот вопрос предназначен для предотвращения автоматической отправки данных форм спам-ботами.
Смайлики
:D :) ;) :( :o :shock: :? 8-) :lol: :x :P :oops: :cry: :evil: :twisted: :roll: :!: :?: :idea: :arrow: :| :mrgreen: :geek: :ugeek:
BBCode ВКЛЮЧЕН
[img] ВКЛЮЧЕН
[flash] ВЫКЛЮЧЕН
[url] ВКЛЮЧЕН
Смайлики ВКЛЮЧЕНЫ
Обзор темы
   

Развернуть Обзор темы: поле ввода вывести реквизит из справочника отличный от наим.

Re: поле ввода вывести реквизит из справочника отличный от н

Сообщение Elizarov.Aleksey » 01 мар 2019, 10:27

Вопрос снят. решил другим путем. просто подвязав к справочнику из номенклатуры.

поле ввода вывести реквизит из справочника отличный от наим.

Сообщение Elizarov.Aleksey » 01 мар 2019, 08:53

Добрый день. Подскажите как в поле ввода вывести реквизит из справочника отличный от наименования.
Код: выделить все
&НаСервереБезКонтекста
Процедура ТрансформаторыТипОбработкаВыбораНаСервере(ВыбранноеЗначение)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Трансформатор.НаименованиеТип КАК НаименованиеТип
      |ИЗ
      |   Справочник.Трансформатор КАК Трансформатор";
   
   //Запрос.УстановитьПараметр("НаименованиеТип", ВыбранноеЗначение.НаименованиеТип);
   
   Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл   
      ВыбранноеЗначение = Выборка.НаименованиеТип;   
   КонецЦикла;   
     НаименованиеТип = ВыбранноеЗначение;
     НаименованиеТип = НаименованиеТип;
      
КонецПроцедуры

&НаКлиенте
Процедура ТрансформаторыТипОбработкаВыбора(Элемент,НаименованиеТип, СтандартнаяОбработка )   
   СтандартнаяОбработка = Ложь;   
   НаименованиеТип = Строка(НаименованиеТип);
   ТрансформаторыТипОбработкаВыбораНаСервере(НаименованиеТип);
КонецПроцедуры
К строке поле прировнял, в отладке значение верное выдает, но поле пустое, и ошибку не выдает.

Вернуться наверх

cron