Тема для тех, кому лень создавать новую тему :)

В данном разделе можно задавать вопросы по программированию на платформе 1С:Предприятие 8.
(Раздел предназначен для тех, кто уже прошел обучение в нашем учебном центре)

p.s. Просьба задавать вопросы только по программированию. На вопросы по типовым конфигурациям обычно не отвечаю по двум причинам
1. В последнее время редко с ними работаю.
2. Чтобы ответить на вопрос требуется: установить соответствующую базу нужного релиза, смоделировать ситуацию, и только после этого возможно залезть в конфигуратор и разобраться что не так (к сожалению, у меня нет столько времени).

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 26 июл 2017, 12:05

Здравствуйте! У меня никак не получается организовать запрос: Если в регистре сведений СрезПоследних отсутствует запись с единицей измерение=т., тогда берем последнюю запись с любой единицей измерения. Помогите, пожалуйста! Может кто-то сталкивался с похожей задачей.
Sveta
 
Сообщений: 34
Зарегистрирован: 03 май 2012, 16:38

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение skameykin22 » 20 авг 2017, 11:28

И как решили свой вопрос?
skameykin22
 
Сообщений: 1
Зарегистрирован: 20 авг 2017, 11:14
Откуда: Санкт-Петербург

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 31 авг 2017, 12:29

Сначала отобрала в запросе данные из СрезПоследних с единицей измерения "т", потом в отобрала данные из СрезПоследних все остальные без единицы измерения "т". Далее связала полученные две таблицы
Выбрать ЕстьNULL(СрезПоТонне.НужноеПоле,СрезВсего.НужноеПоле) из СрезПоТонне
полное соединение СрезВсего по СрезПоТонне.Номенклатура=СрезВсего.Номенклатура
Как-то так...
Sveta
 
Сообщений: 34
Зарегистрирован: 03 май 2012, 16:38

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Elizarov.Aleksey » 13 янв 2018, 00:06

Доброго времени суток. Всех с прошедшими праздниками!)))
Хотел отдельно поздравить Сергея с новым годом. что бы новый год был еще лучше!! Спасибо Вам, жалею что не смог в последний день не смог придти.
По теме, кто подскажет в каком блоке было про печатную форму с переносам по страницам?
Печатная форма "Акт на передачу прав" БУХ 2.0 https://cloud.mail.ru/public/BXV7/W7cgtms7W работает все кроме переноса по страница :D может кому пригодиться)) доделаю выложу полностью исправную. Изображение
Elizarov.Aleksey
 
Сообщений: 2
Зарегистрирован: 12 янв 2018, 23:46

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Elizarov.Aleksey » 14 янв 2018, 07:15

Разобрался со страницами. полностью готовая форма. https://cloud.mail.ru/public/MdDG/6gjC2nMRe
Elizarov.Aleksey
 
Сообщений: 2
Зарегистрирован: 12 янв 2018, 23:46

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Ирина » 06 июн 2018, 09:41

Добрый день.Необходимо, чтобы в справочнике если ВидДокумента инструкция и ДатаДействияОкончания меньше текущей даты, строки окрашивались в красный цвет. В модуле формы в процедуре ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)добавила небольшой код,который создает условие в Условном оформление списка. Когда захожу в 1с в режиме предприятие Условие создается, но не отрабатывает. Не подскажите в чем может быть проблема? Спасибо.

//=================================================
Список.УсловноеОформление.Элементы.Очистить();
ЭлементУсловногоОформления =Список.УсловноеОформление.Элементы.Добавить();

ГруппаЭлементовОтбора = ЭлементУсловногоОформления.Отбор.Элементы.Добавить(Тип("ГруппаЭлементовОтбораКомпоновкиДанных"));
ГруппаЭлементовОтбора.ТипГруппы = ТипГруппыЭлементовОтбораКомпоновкиДанных.ГруппаИ;

ЭлементОтбора = ГруппаЭлементовОтбора.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ДатаОкончанияДействия");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Меньше;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = ТекущаяДата();

ЭлементОтбора = ГруппаЭлементовОтбора.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
ЭлементОтбора.ЛевоеЗначение = Новый ПолеКомпоновкиДанных("ВидДокумента");
ЭлементОтбора.ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
ЭлементОтбора.Использование = Истина;
ЭлементОтбора.ПравоеЗначение = "Инструкция";

ЭлементОформления = ЭлементУсловногоОформления.Оформление.НайтиЗначениеПараметра(Новый ПараметрКомпоновкиДанных("ЦветТекста"));
ЭлементОформления.Использование = Истина;
ЭлементОформления.Значение = Новый Цвет(255, 0, 0);
//
Ирина
 
Сообщений: 2
Зарегистрирован: 06 июн 2018, 08:40

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Ирина » 06 июн 2018, 16:35

Вопрос отпал.Разобралась.
Ирина
 
Сообщений: 2
Зарегистрирован: 06 июн 2018, 08:40

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение Sveta » 03 июл 2018, 16:35

Добрый день!
Как правильно организовать добавление стандарных команд формы на командную панель? Необходимо добавить в командную панель табличных частей документа кнопку "Найти".
Я делаю так
Для каждого Элемент из ЭтаФорма.Элементы Цикл
Если типЗНЧ(Элемент) = Тип("ТаблицаФормы") Тогда
//вот здесь неправильно у меня, так как я добавляю новую, а надо подключиться к существующей стандартной команде "Найти"
Команда = ЭтаФорма.Команды.Добавить(Элемент.Имя + "Найти");
Команда.Действие = Элемент.Имя + "Найти";
//

Кнопка = ЭтаФорма.Элементы.Добавить(Элемент.Имя + "ВыполнитьНайти", Тип("КнопкаФормы"), Элемент.КоманднаяПанель);
Кнопка.Заголовок = "Найти";
Кнопка.Отображение = ОтображениеКнопки.КартинкаИТекст;
Кнопка.ИмяКоманды = Элемент.Имя + "Найти"; //здесь должна быть команда "Найти" из стандартных команд данной табличной части
КонецЕсли;
КонецЦикла;
Sveta
 
Сообщений: 34
Зарегистрирован: 03 май 2012, 16:38

Re: Тема для тех, кому лень создавать новую тему :)

Сообщение admin » 03 июл 2018, 21:27

Добрый день!
Попробуйте так:
Код: выделить все
   Для каждого Элемент Из Элементы Цикл
      Если ТипЗнч(Элемент)=Тип("ТаблицаФормы") Тогда
         Элемент.КоманднаяПанель.ПодчиненныеЭлементы[Элемент.Имя+"Найти"].ТолькоВоВсехДействиях = Ложь;
         Элемент.КоманднаяПанель.ПодчиненныеЭлементы[Элемент.Имя+"Найти"].Отображение = ОтображениеКнопки.КартинкаИТекст;
      КонецЕсли;
   КонецЦикла;   
admin
Администратор
 
Сообщений: 240
Зарегистрирован: 14 дек 2011, 11:11

Пред.

Вернуться в Вопросы по программированию

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1

cron