Страница 1 из 1

поле ввода вывести реквизит из справочника отличный от наим.

СообщениеДобавлено: 01 мар 2019, 08:53
Elizarov.Aleksey
Добрый день. Подскажите как в поле ввода вывести реквизит из справочника отличный от наименования.
Код: выделить все
&НаСервереБезКонтекста
Процедура ТрансформаторыТипОбработкаВыбораНаСервере(ВыбранноеЗначение)
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Трансформатор.НаименованиеТип КАК НаименованиеТип
      |ИЗ
      |   Справочник.Трансформатор КАК Трансформатор";
   
   //Запрос.УстановитьПараметр("НаименованиеТип", ВыбранноеЗначение.НаименованиеТип);
   
   Выборка = Запрос.Выполнить().Выбрать();
   Пока Выборка.Следующий() Цикл   
      ВыбранноеЗначение = Выборка.НаименованиеТип;   
   КонецЦикла;   
     НаименованиеТип = ВыбранноеЗначение;
     НаименованиеТип = НаименованиеТип;
      
КонецПроцедуры

&НаКлиенте
Процедура ТрансформаторыТипОбработкаВыбора(Элемент,НаименованиеТип, СтандартнаяОбработка )   
   СтандартнаяОбработка = Ложь;   
   НаименованиеТип = Строка(НаименованиеТип);
   ТрансформаторыТипОбработкаВыбораНаСервере(НаименованиеТип);
КонецПроцедуры
К строке поле прировнял, в отладке значение верное выдает, но поле пустое, и ошибку не выдает.

Re: поле ввода вывести реквизит из справочника отличный от н

СообщениеДобавлено: 01 мар 2019, 10:27
Elizarov.Aleksey
Вопрос снят. решил другим путем. просто подвязав к справочнику из номенклатуры.