Вывод макетов с разной шириной колонок в одну печатную форму

В этом разделе рассказываются "тайны" программирования на платформе 1С:Предприятие 8.х

(раздел будет интересен тем, кто уже программирует на 1С)

Вывод макетов с разной шириной колонок в одну печатную форму

Сообщение admin » 21 авг 2013, 14:34

Иногда возникает необходимость вывода областей из разных макетов или готовых печатных форм с разной шириной колонок в одну печатную форму.

Вот предлагаемый мною вариант:

Код: выделить все
...
   ТабДок = Новый ТабличныйДокумент
   ВывестиВОднуПечФорму(ТабДок,Область1);
   ВывестиВОднуПечФорму(ТабДок,Область2);
...   

Процедура ВывестиВОднуПечФорму(Приемник,Источник)

   Для каждого Область Из Источник.Области Цикл
      Область.СоздатьФорматСтрок();
   КонецЦикла;
   
   ВысотаТаблицы = Приемник.ВысотаТаблицы;
   
   Приемник.Вывести(Источник);
   
   Для каждого Область Из Источник.Области Цикл
      Для НомКол=1 По Источник.ШиринаТаблицы Цикл
         ШиринаКолонки = Источник.Область(Область.Верх, НомКол,Область.Верх, НомКол).ШиринаКолонки;
         Приемник.Область(ВысотаТаблицы+Область.Верх, НомКол,ВысотаТаблицы+Область.Верх, НомКол).ШиринаКолонки = ШиринаКолонки;
      КонецЦикла;
   КонецЦикла;
   
КонецПроцедуры
admin
Администратор
 
Сообщений: 233
Зарегистрирован: 14 дек 2011, 11:11

Вернуться в Книга тайн 1С

Кто сейчас на форуме

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1