Страница 1 из 1

Вывод макетов с разной шириной колонок в одну печатную форму

СообщениеДобавлено: 21 авг 2013, 14:34
admin
Иногда возникает необходимость вывода областей из разных макетов или готовых печатных форм с разной шириной колонок в одну печатную форму.

Вот предлагаемый мною вариант:

Код: выделить все
...
   ТабДок = Новый ТабличныйДокумент
   ВывестиВОднуПечФорму(ТабДок,Область1);
   ВывестиВОднуПечФорму(ТабДок,Область2);
...   

Процедура ВывестиВОднуПечФорму(Приемник,Источник)

   Для каждого Область Из Источник.Области Цикл
      Область.СоздатьФорматСтрок();
   КонецЦикла;
   
   ВысотаТаблицы = Приемник.ВысотаТаблицы;
   
   Приемник.Вывести(Источник);
   
   Для каждого Область Из Источник.Области Цикл
      Для НомКол=1 По Источник.ШиринаТаблицы Цикл
         ШиринаКолонки = Источник.Область(Область.Верх, НомКол,Область.Верх, НомКол).ШиринаКолонки;
         Приемник.Область(ВысотаТаблицы+Область.Верх, НомКол,ВысотаТаблицы+Область.Верх, НомКол).ШиринаКолонки = ШиринаКолонки;
      КонецЦикла;
   КонецЦикла;
   
КонецПроцедуры